Skip to main content

Notifications

Announcements

No record found.

Community site session details

Community site session details

Session Id :
Small and medium business | Business Central, N...
Unanswered

Could not connect to the SQL database

(0) ShareShare
ReportReport
Posted on by 645

SYMPTOM:

When we install Business Central to the server, you might receive the following error messages:

SQL Server Database Components
Cronus Sample Database for Microsoft Dynamics 365 Business Central
Fatal error during installation.

Could not connect to the SQL database.  (-2147467259   master      ). This can be caused by insufficient permissions. Indirect permissions through Windows group memberships may not work as expected when User Account Control (UAC) is turned on.
Web Server Components
Web Server Components
Fatal error during installation.

pastedimage1644327053835v1.png

Cause:

The problem was in the TLS 1.0 and 1.1

RESOLUTION:
After turning on the TLS  1.2, the installation was completed successfully.

Reference 

KB3135244 - TLS 1.2 support for Microsoft SQL Server

Categories:

Under review

Thank you for your reply! To ensure a great experience for everyone, your content is awaiting approval by our Community Managers. Please check back later.

Helpful resources

Quick Links

Dynamics 365 Community Update – Sep 16th

Welcome to the next edition of the Community Platform Update. This is a weekly…

Announcing Our 2024 Season 2 Super Users!

A new season of Super Users has arrived, and we are so grateful for the daily…

Dynamics 365 Community Newsletter - September 2024

Check out the latest community news

Leaderboard

#1
André Arnaud de Calavon Profile Picture

André Arnaud de Cal... 283,860 Test role Public

#2
Ludwig Reinhard Profile Picture

Ludwig Reinhard 229,831 Microsoft Employee

#3
Martin Dráb Profile Picture

Martin Dráb 225,155 Moderator

Overall leaderboard

Featured topics

Product updates

Dynamics 365 release plans